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1. Introduction 

This manual contains a short introduction to the Tosmana software. Although 

this manual describes the basic features of QCA - the main method 

implemented in Tosmana -this is not a general introduction to the method. 

Please refer to the Getting Started with TOSMANA guide found on the website 

if you wish a short introduction to the main features of the software. 

Currently, TOSMANA supports crisp-set QCA (csQCA) as first introduced 

Charles Ragin with his book “The Comparative Method”1 and multi-value QCA 

(mvQCA). From Version 1.5., fuzzy-set QCA (fsQCA) is included with Tosmana 

as well. 

Tosmana is work in progress and currently a sideline product of my work. 

Therefore, check all calculations performed with the software with other 

software packages prior to publication. You can find an overview of available 

software for QCA analysis on the Website of the Compasss group in the 

software section (http://www.compasss.org). 

With the release of version 1.4., the development of Tosmana resumed after a 

number of years without work on the programme. Some few features were 

added, but the main changes from version 1.3 to 1.4 did consist in a clearing 

out of legacy issues in the software and general clean-up of code. Version 1.4 

replaced the main window and redesigned the handling of data, allowing the 

direct import from a spreadsheet without the need to save the data. Version 1.5 

introduces fsQCA to Tosmana. 

  

                                                 

1 Ragin, C. C. (1987) The Comparative Method. Moving Beyond Qualitative and Quantitative Strategies, 

University of California Press, Berkeley. 
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2. Using Tosmana 

Tosmana comes as a ZIP-file. Simply extract the zip-file and run the file named 

tosmana.exe. 

Please only download the file from the website (http://www.tosmana.net) and 

check the checksum to avoid a faulty download. 

3. Constructing your data set 

After the start of the software, the main window shows up, in which data files 

are created, loaded and saved, and from where the calculation window is 

called.  

Loading and Importing Data 

Loading a file into Tosmana 

Load a file created (and saved) by Tosmana by selecting File > Open from the 

menu bar in the main window. Please note that only files created with Tosmana 

and saved in the XML (extended mark-up language) file format can be loaded 

with the Open item. If you have saved files with the extension tosmana in earlier 

versions of the software, you can still open them with the current software 

version.  

Importing from Spreadsheet programmes 

The easiest way to include data in Tosmana is to copy data directly from a 

spreadsheet programme. By selecting File > Import from Clipboard data can be 

directly pasted from a spreadsheet programme without the need of saving the 

data to a file.  

In Tosmana, one variable always has to be included which can be used as 

Case-ID for your data set.  

The first row must contain the variable names. To import the data, simply select 

the data to be used and copy it (to the clipboard). Then, in Tosmana, select File 

> Import from Clipboard. 

In a first step, you should save the data as a Tosmana XML-file (File > Save 

as). The import features tries to identify the type of variables imported. If metric 

http://www.tosmana.net/
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data is included, you have to set thresholds before you can perform an QCA 

analysis. Please refer to the section on variable transformation for further 

information. 

Creating and saving files  

By selecting File > New a new Tosmana data set will be created. You can add 

variables to the data set by selecting Dataset > Enter new Variable from the 

menu bar. As soon as all variables are added, you can add the cases of the 

data set simply by entering them in the data matrix of the main window. To 

change the Variable name you have to enter the variable edit window described 

below. 

Selecting File > Save in the main menu bar saves the data set. If you wish to 

use your data set in other applications (Excel or fs/qca) you may also save the 

file as a csv or dat file (choose Export). TOSMANA save the file in XML format. 

Editing the data set 

You might change the content of the data matrix at any time by changing the 

data in the main window. Please note that you have to re-open the mvQCA 

calculation window to use the new data in your calculation. If you want to add a 

new row (case), just enter the data in the last row of the data set. If you wish to 

delete a case, click on the row header of the case you wish to delete and press 

the delete button on your keyboard.  

Adding and editing variables 

To add a new variable please select Dataset > Enter new variable. Edit the 

name of the new variable and press ok. The new variable will then appear in the 

data set.  

If you wish to change the attributes of an existing variable, please click on the 

column header and select edit condition. 

 To change the name of the variable click on the button labelled change name and 

enter the new variable name. 

 To remove a variable entirely, select the variable name in the Variable Settings 

window and press the button labelled remove. 

 You may add a description to a variable in the description field. 
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Replacing multiple data entries 

If you wish to replace multiple data cell entries with the same value, you may do 

so using the replace function (select Edit > Replace). Define the search value 

and the new value to replace it and select all variable where this replacement is 

done. Press ok and the replacement will take place.  

Variable transformation 

The menu item Transformation in the Variable Settings Window defines how to 

convert the raw data to data used by mvQCA. There are four different options, 

which can be set for each variable: 

 use original values (1:1): Using this option indicates that the raw data is used as it 

is with mvQCA. Please note that all data must be of numerical type and that 

missing data always has to be noted with an '-'. Variables containing the name of 

the cases should be changed to use as case ID. If this is not the case Tosmana 

will produce errors. 

 no Transformation possible: If this option is set, the variable can not be 

transformed and it can not be used with the software. The sense of this is to 

exclude variables which can not be translated by the standard rules yet but which 

may be used in future (like calendar dates etc.) 

 use as case ID: If this variable is set, the variable can only be used as case ID. 

 use Thresholds: If this variable is set, you can use the threshold setter described 

below to set the thresholds dynamically while working with TOSMANA. Please 

note that all data must be of numerical type and that missing data always has to 

be noted with a '-'. 
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Transforming Scale Data 

To transform scale data to stepped conditions suitable for mvQCA analysis, 

thresholds must be set to recode the data. TOSMANA provides two ways to do 

so: Thresholds can be set directly by hand or thresholds can be set interactively 

by using the 'Thresholdssetter'. 

To set the thresholds directly, choose Edit > Variable Settings from the menu 

bar and select the condition to set the thresholds (double click the row header). 

If the option “use thresholds” is selected as transformation mode, the button edit 

can be pressed. The thresholds are entered by using '.' (dot) to separate 

decimals and ';' to separate multiple thresholds. 

Using the "Thresholdsetter" Window 

If one or more Variables do contain metric scaled data, the data must be 

transformed to an ordinal scale before it can be used with cs- or mvQCA. To do 

this, the variable must be set to be transformed with threshold(s) in the Variable 

Settings window (set the Transformation item to use Thresholds). Then the 

Threshold Settings Window can be opened with Tools > Thresholdsetter in the 

main window.  
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In the central panel the distribution of data is shown. Each orange box 

represents one case. The green lines represent the current thresholds. The 

values of the thresholds are noted above the threshold line if the option is set 

(lower left corner, show threshold values). The number of decimals shown can 

also be set (4). The thick red line is the median (the line can be toggled on / off 

with the option in the lower left corner (3)). The name of the variable edited is 

shown in the upper left corner of the window (1).  

The number of thresholds used with the variable can be selected with the 

dropdown list in the upper right corner (2).  

To move a threshold simply place the mouse on the wanted threshold (the 

mouse pointer will change) and press the left mouse button. The move the line 

by moving the mouse (still pressing the left button) and release the mouse 

button with the value wished. 

Recode Conditions 

To recode a condition into a new condition, select Tools > Recode Condition 

from the menu bar. Select the condition to be recoded and check the proposed 

name of the new condition. By selecting the “old” values found in the left box, 

these might either be used unchanged in the new condition (“1:1” button) or 

assigned new values (enter the new value in the text field under the Convert to 

button and press this button.   
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4. Data Analysis: csQCA and mvQCA 

One of the main goals of Tosmana is to perform minimization on Boolean and 

on Multi-Value Data sets. This is done from the analysis window (named 

(mv)QCA). Call the analysis window from the menu bar: Tools > Start (mv)QCA 

or by pressing F9. 

 

Selecting variables for analysis 

Before the calculation can be done, the variables for the analysis have to be 

chosen (1). Use the arrow buttons to select the outcome and the conditions. 

Please note that the use of a case descriptor is necessary in Tosmana. Variable 

values have to be of the type {0,1} for Boolean analysis and {0,..,n} for multi 

value analysis. If you choose a variable with non-numerical data as outcome or 

condition, an error window will show up. 
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Visualizing your data 

Up to five conditions can be displayed in a graph by pressing the visualize 

button (2). See the chapter on the Visualizer below for details. 

Calculation configuration 

The configuration of the calculation can be set in the right half of the (mv)QCA 

window (3). The configuration labels are to be understood as follows:  

 Explain: Those outcomes which are explained by the solution. 

 Include for reduction: Outcomes allowed to be included in the reduction of the 

implicants as logical remainders (“don’t cares”). 

 Exclude: Outcomes, which are excluded from minimization.  

 

Regularly, Tosmana shows the expressions in the solution with set notation. If 

the option Use upper-/lowercase notation is checked, the notation found in the 

discussions of QCA by Charles Ragin is used. 

If you wish to see the used simplifying assumptions, enable the compute 

simplifying assumptions checkbox. With a large number of conditions this 

feature can be time demanding. 

Starting the calculation 

Start the calculation with the Full Analysis button (4). If the output mode  is set 

to “text only”, the results will be shown in the results window (see below). Else, 

the result report will appear in a new window of the Internet Explorer. If you only 

want to see the QCA results, these can be quickly derived by pressing the just 

results button (5). 

Only Show Implicants 

To only get a list of the prime implicants press the show implicants (6) button. In 

the prime implicant window coming up you can then see the prime implicants for 

your selection of conditions and settings. You may filter the list by cases. With a 

click on a prime implicant in the list the cases implied by this implicant are 

shown.  
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The Tosmana Report 

When the calculation is finished, the result report opens in the Tosmana result 

window or, if selected, in the standard web browser. 

You will find the settings of the calculation and (if selected) the data matrix first 

in the report. At the end, the solution and (if the option is set) the simplifying 

assumptions are reported. Tosmana can either use upper-/lowercase notation 

to display the results or use strict set notation. As Tosmana also allows more 

than two possible values for each condition, the upper-/lowercase solution can 

only be used to display strictly dichotomous data sets. 

Copy any parts of the report to the clipboard by clicking the right mouse button 

and selecting copy in the popup-menu.  

In addition, you can directly add solutions to the Boolean Calculator by 

highlighting the solution and selecting Add to Boolean Calculator from the 

context menu pressing the right mouse button.2  

                                                 

2 Currently this only works with dichotomous data sets. The use of set notation in the report is 

required (unselect the Use Uppercase / Lowercase notation option in the mvQCA window. 
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5. The Visualizer 

Tosmana allows the user to display a Boolean data set with up to five 

independent conditions to be displayed graphically. To do this, select the 

conditions in the mv(QCA) window and press the visualize button.  

Please note that at the recent stage it is only possible to save the created graph 

as a bitmap file, which is rather large, but this can be edited and compressed in 

almost every graphic application.  

In the Visualizer, you can toggle between Colour and Black/White display and 

select which information is shown. You might also highlight or prime implicants 

solutions of your choice. 
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6. The Boolean Calculator 

The Boolean Calculator allows simple calculation on Boolean Expressions like 

intersections and complements. To perform such a calculation, the Boolean 

Expressions have to be entered into the calculator. This is done in prefix 

notation just like using a standard pocket calculator: First the single expressions 

are entered which then are connected by + and *. When the logical expression 

is entered, it can be added to the lower calculation box by pressing the “add” 

button. An intersection of two logical expressions is calculated by selecting the 

two expressions from the expression list (using the shift key to select multiple 

entries) and then pressing the “computer intersection” button. The complement 

of a logical expression can be calculated by selecting the expression from the 

list and pressing the “compute complement” button. 

Logical expressions can be directly added from the TOSMANA report by 

highlighting the solution and selecting Add to Boolean Calculator from the 

context menu pressing the right mouse button.  
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7. Data Analysis: fsQCA 

From version 1.5, TOSMANA also enables users to perform standard fsQCA 

calculations. Please press F10 or select Analysis > Start fsQCA from the menu 

bar and the fsQCA window appears. Similarly to the cs- and mvQCA analysis, 

the variables for the analysis have to be chosen (1) and the outcome value to 

be specified has be selected (2).  

 

In a first step then, the software allows to check for necessary conditions (3). In 

addition, the fsQCA truthtable with consistency values can be calculated (4). To 

perform a full fsQCA analysis, please define the consistency cut-off (6) and the 

frequency threshold (5) press the full analysis (9) button. A number of further 

option can be set as with the csQCA analysis described above. 
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The XY Plot window 

In addition to the analysis of consistency addressed above, TOSMANA also 

allows to study fuzzy set relations. To do so, please open the XY Plot from the 

main window (Analysis – XY Plot, or F8). One or multiple variables can be 

included on each axis (1) – select multiple variable by keeping ctrl pressed 

while selecting. Press the create plot button (2) to draw the XY Plot. In addition, 

the software calculates the consistency and the coverage values for the fuzzy 

set relation (X  Y). 

 

 

Single points in the plot show the individual cases. Cases sharing the same 

values are combined to a single, larger point. Hover the mouse over a point to 

see the case ID and the values of the case(s). To show all data, deselect the 

checkbox hide labels (3). Save the shown plot as an image by pressing save 

plot as image (4). 
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8. About the software 

Tosmana is freeware and it comes as it is: There is no guarantee for 

correctness of any part of the results provided by the program.  

Tosmana is work in progress and currently a sideline product of my work. 

Therefore, all calculations performed with the software should be checked 

with other software packages prior to publication. An overview of 

available software for QCA analysis can be found on the Website of the 

Compasss group in the software section (http://www.compasss.org). 

Citing, Technical and contact information: 

If you use Tosmana please cite like this: 
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Please do also notice the following descriptions for a quick start with 

TOSMANA: 

Cronqvist, Lasse. 2016: Getting started with TOSMANA. Univ. of Trier. 

<http://www.tosmana.net> 
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