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1. Introduction

Within this document the reader will find a short guide to get started with the Tool for Small-

N Analysis Tosmana. Although the basic features of QCA, the main method implemented in 

Tosmana, are  described,  this is  not a general  introduction to this method.  QCA was first 

introduced to the social sciences by Charles Ragin with his book “The Comparative Method”1 

where  he  sought  to  move  beyond  the  qualitative-quantitative  gap,  by  introducing  a  new 

method to combine the strengths and to reduce the problems of either approach. This resulted 

in  Qualitative  Comparative  Analysis – QCA.  The  main  goal  of  QCA  is  to  reduce  the 

complexity of data sets by using Boolean algebra. Since 1987 several software programs have 

been created to implement this method. In every new program several things had changed: 

New algorithms have been introduced and more powerful computers allowed extending the 

limitations  regarding  the  number  of  conditions  to  be  treated  simultaneously.  With  fs/qca 

(Fuzzy Set Qualitative Comparative Analysis, http://www.fsqca.com) a graphic user interface 

(windows style) was used for the first time, and the 12 variable limit of QCA3 was overcome.

Tosmana also implements classical Boolean algebra, but it seeks to tackle one of the main 

limitations of QCA - its restriction to Boolean sets: Every element of a data set has to be T 

(true) or F (false), but often we want to use more condition values like {low, medium, high}. 

Therefore Tosmana introduces Multi-Value Minimization as an additional feature of Boolean 

Minimization, but it also can be used for Boolean Minimization. As this is a software manual, 

the method as such is not discussed here, but the user should read available introductions to 

Multi-Value Minimization.2 Please also visit the Tosmana resource site, where a list of further 

readings is found.

As Tosmana is work in progress, many details of the software are subject to changes.  

1 Ragin, C. C. (1987) The Comparative Method. Moving Beyond Qualitative and Quantitative 
Strategies, University of California Press, Berkeley.
2. Cronqvist,  Lasse (2003): “Using Multi-Value Logic Syntheses in Social Science”.  Paper 
presented at the 2nd General Conference of the European Consortium for Political Research 
(ECPR) Marburg:. Found on http://www.tosmana.net/resources/. 
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2. Installing Tosmana

From version 1.3.,  TOSMANA comes with an installer  which takes you through the full 

installation process.

Tosmana is using the .NET Framework, a programming platform provided by Microsoft. The 

advantage  of  using  this  framework  is  that  it  takes  care  of  many  details  of  the  software 

creation,  so  that  the  programmer  can  concentrate  on  the  central  topics.  This  means  that 

creating Tosmana is much faster with .NET than without a programming framework. But this 

also means that the user has to install a version of the  .NET Framework if there is no such 

framework already installed on the system.  From version 1.3.  on,  the Framework will  be 

installed by the installer if needed.

3. The Main Window

If the .NET Framework is installed correctly, Tosmana can be started easily by running it out 

of the windows explorer or from the start  menu like any other Windows program. When 

Tosmana is started, the main window shows up, in which data files are created, loaded and 

saved, and from where the calculation window is called.

Opened files are shown the main window. All tools for data manipulation and analysis can be 

called from the menu bar in the main window (see below). The data of the current data set is 

shown in the main window and can be edited directly. 

All information on the variables is directly shown in the main window. A green flag next to 

the variable name does not contain numerical data and can only be used as a case id. The 

numbers below a variable are the threshold(s) used to create the (MV)QCA data set.  If a 

warning sign is displayed below a variable, this indicates that the thresholds have to be set.

The recoded data, which will be used with QCA or MVQCA, is shown in the MVQCA Data 

tab.
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4. Data sets

Creating and saving files 

By selecting File > New a new Tosmana data set will be created. You can add variables to the 

data set by selecting Data > New Variable from the menu bar. As soon as all variables are 

added, you can add the cases of the data set simply by entering them in the data matrix of the 

main window. To change the name or other information of a variable, click on the column 

header of the variable in the main window and select edit variable.

Selecting File > Save in the main menu bar saves the data set. If you wish to use your data set 

in other applications (Excel or fs/qca) you may also save the file as a csv or dat file (choose 

Export).  The file is saved in XML format but is assigned the extension .tosmana. Selecting a 

file  with  this  extension  allows  to  open  it  directly  with  TOSMANA  from  the  windows 

explorer.

Loading and Importing Data

Loading a file into Tosmana

A file created (and saved) by Tosmana can be loaded by selecting File > Open from the menu 

bar in the main window. Please note that only files created with  Tosmana and saved in the 

XML (extended mark-up language) or the TOSMANA file format can be loaded with the 

Open item. Files with the extension .tosmana are regular XML files, but using this distinct file 

extension allows the use to run TOSMANA by opening the data file.  If you save files as 

Tosmana-files, you can open these file by selecting them in the windows explorer.

Importing from Excel

By selecting File > Import > Excel a CSV-File saved by Excel can be imported to Tosmana 

(This feature has been tested with Excel97 and Excel2000,  but it  should work with other 

releases as well).  First, you have to assure yourself that a variable is included which can be 

used as Case-ID for your data set. To import data from Excel to Tosmana please follow these 

instructions:

In Excel:

1. Open the data set in Excel.

2. Switch to the sheet which is going to be exported to Tosmana

3. Select File > Save As. Select “CSV-File (*.csv)” as File Type in the save dialog window.

4. Type the filename to be used, save the file.

5. Close the worksheet
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In Tosmana 

In Tosmana select File > Import > Excel and select the file just saved. The import feature of 

Tosmana recognises the variable type (case descriptors, interval scale, ordinal scale). You can 

review these settings and then the data appear in the  Tosmana Main Window. You should 

then save the data as a Tosmana XML-file.

Importing data from SPSS

Also SPSS .dat files can be imported with File > Import > SPSS-Data (*.dat). As with Excel 

imports, you first have to assure yourself that a variable is included which can be used as 

Case-ID for  your  data set.  Please also notice  that  all  variables  are  considered to be of a 

nominal type. You may change this in the “variable settings” section (see below). To import 

data from SPSS to Tosmana please follow these instructions:

In SPSS:

1. Open the data set in SPSS.

2. Select  File  >  Save  As. Select  “ Tab-Limited  *.dat” as  File  Type  in  the  save  dialog 

window.

3. Type the filename to be used. 

4. Save the file. 

In Tosmana:

In Tosmana select File > Import > SPSS-Data (*.dat) and select the file just saved. The data 

should  now appear  in  the  Tosmana Main  Window.  You should  then  save  the  data  as  a 

Tosmana XML-file.

Importing from fs/qca

By selecting File > Import > Excel or fs/qca file a DAT-File saved by fs/qca can be imported 

to Tosmana.

First, you have to assure yourself that a variable is included which can be used as Case-ID for 

your data set. Please also notice that all variables are considered to be of a nominal type. You 

may change this in the “variable settings” section (see below). To import data from fs/qca to 

Tosmana please follow these instructions:

In fs/QCA:

1. Open the data set in fs/qca.

2. Select File > Save As. Select “comma” as File Type in the save dialog window.

3. Type the filename to be used. 
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4. Save the file. 

In Tosmana 

In Tosmana select File > Import > Excel or fs/qca file and select the file just saved. The data 

should  now appear  in  the  Tosmana Main  Window.  You should  then  save  the  data  as  a 

Tosmana XML-file.

Editing the data set

You might change the content of the data matrix at any time by changing the data in the main 

window. Please note that you have to open a new calculation window to use the new data in 

your calculation. If you want to add a new row (case), just enter the data in the last row of the 

data set. If you wish to delete a case, click on the row header of the case you wish to delete 

and press the delete button on your keyboard. 

Adding and editing variables

To add a new variable please select Data > New variable. Edit the name of the new variable 

and press ok. The new variable will then appear in the data set. 

If you wish to change the attributes of an existing variable, please click on the column header 

and select edit variable.

• Change the name or the description of the variable by entering the new values in the edit  

variable menu.

• To remove a variable entirely, press the delete button.

Variable transformation

The menu item  Transformation defines how the raw data is converted to the data used by 

MVQCA. There are four different options, which can be set for each variable:

• use original values (1:1): Using this option indicates that the data is used as it is with 

MVQCA. Please note that all data must be of numerical type and that missing data always 

has to be noted with an '-'. Variables containing the name of the cases should be set as use 

as case ID. If this requierement is not met, Tosmana will produce errors.
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• use as case ID: If this variable is set, the variable can only be used as case ID.

• use Thresholds: If this variable is set, you can use the threshold setter described below to 

set the thresholds dynamically while working with TOSMANA. Please note that all data 

must  be  of  numerical  type  and  that  missing  data  always  has  to  be  noted  with  a  '-'. 

Thresholds can be entered directly or be set by using the thresholdssetter.

Replacing multiple data entries

If you wish to replace multiple data cell entries with the same value, you may do so using the 

replacement window (select  Edit > Replace). Define the search value and the new value to 

replace it and select all variable where this replacement is done. Press ok and the replacement 

will take place. You can use this feature to change the missing data value in the data set to the 

needed '-' in TOSMANA all at once. 

Transforming Scale Data

To transform scale data to stepped variable suitable for MVQCA analysis, thresholds must be 

set to recode the data. TOSMANA provides two ways to do so: Thresholds can be set directly 

by hand or thresholds can be set interactively by using the 'Thresholdssetter'.

To set the thresholds directly, click the column header of the column with the variable and 

select  edit variable.  If the option “use thresholds” is selected as transformation mode, the 

button setter can be pressed. The thresholds are entered by using '.' (dot) to separate decimals 

and ';' to separate multiple thresholds.

Using the "Thresholdsetter" Window

If one or more variables are containing data, which is scaled on an interval scale, the data 

must be transformed to an ordinal scale before it can be used with MVQCA. 
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In the central panel the distribution of the data is shown. Each orange box represents one case. 

The green lines represent the thresholds. The values of the thresholds are noted above the 

threshold line, if the option show threshold values is set. The number of decimals shown can 

also be set (3). The thick red line is the median (the line can be toggled on / off with the 

option in the lower left corner (2)).  

To move the threshold simply  place  the mouse on the  threshold  (the  mouse pointer  will 

change)  and press  the  left  mouse  button.  The move the  line  by moving  the  mouse (still 

pressing the left button) and release the mouse button with the value wished.

The number of thresholds used with the variable can be selected with the dropdown list in the 

upper right corner (1). By clicking the  cluster button a simple clustering (average linkage) 

will be performed on the data. 

Recode variables

To recode a stepped variable into a new variable, select  Data > Recode Variable  from the 

menu bar. Select the variable to be recoded and check the proposed name of the new variable. 

By selecting the “old” values found in the left box, these might either be used unchanged in 

the new variable (“1:1” button) or assigned new values (enter the new value in the text field 

under the  Convert to button and press this button. If you wish to undo a coding, select the 

recode expression in the right box and press the undo button.
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5. Data Analysis

The main goal of Tosmana is to perform minimization on Boolean and on Multi-Value Data 

sets. This is done from the analysis window (named  (MV)QCA). Call the analysis window 

from the menu bar: Analysis > Start (MV)QCA.

 

 

1 

3 

4 

2 6 5 

Selecting conditions for analysis

Before the calculation can be done, the conditions for the analysis have to be chosen (red box 

1 in figure 4-1). Use the arrow buttons to select the outcome and the conditions. Please note 

that the use of a case descriptor is necessary in Tosmana. Condition values have to be of the 

type  {0,1}  for  Boolean  analysis  and  {0,..,n}  for  multi  value  analysis.  If  you  choose  a 

condition with non-numerical data as outcome or condition, an error window will show up.

Visualizing your data

Up to five conditions can be displayed in a graph by pressing the visualize button (2). See the 

chapter on the Visualizer below for details.

Figure 4-1 The (MV)QCA Window

10



Selecting the calculation style

Tosmana provides you with three different ways to calculate solutions, which can be selected 

with the Selection Mode drop-down box (3): 

(1) All solutions are calculated and displayed in the result report (Show All)

(2) When more than one solution is possible, the user can select the prime implicants 

used in the  manual selection window (see below), but  Tosmana ensures that the 

solution is minimal (Select if possible)

(3) The user may combine the solution freely in the manual selection window, but this 

means that the solution does not have to be minimal. (Free selection).

Calculation configuration

The configuration of the calculation can be set in the right half of the (MV)QCA window (4). 

The configuration labels are to be understood as follows: 

• Explain:  Those outcomes which are explained by the solution (in QCA2:  Matrix to be 

minimized)

• Include for reduction: Outcomes allowed to be included in the reduction of the implicants 

(in  QCA2:  Matrix  for  computing Prime Implicants – please note that  outcomes to be 

explained had to be included in this matrix in QCA2, in QCA3: “don’t cares”).

• Exclude: Outcomes, which are excluded from minimization. 

Select Notation

Regularly,  Tosmana  shows the  expressions  in  the  solution  with  strict  set  notation.  If  the 

option  Use upper-/lowercase notation is checked, the notation used with QCA2 and QCA3 

can be used instead.

Show Implicants

To only get a list of the prime implicants press the show implicants (6) button. In the prime 

implicant window coming up you can then see the prime implicants for your selection of 

conditions and settings. You may filter the list by cases. With a click on a prime implicant in 

the list the cases implied by this implicant are shown.

Starting the calculation

Start the calculation with the Go button (5). The result report will appear in a new window of 

the Internet Explorer. This window might be saved or printed.
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Manual Selection of Prime Implicants

In the manual selection window prime implicants are selected. If there is a possible choice 

between prime implicants to find the minimal expression, these are displayed in the lower part 

of the window, whilst already selected implicants are displayed in the upper half. These are 

either selected by the user or by the software, indicating that these prime implicants have to be 

included in a minimal solution. Cases not represented by already selected implicants have 

green-colored columns to indicate this. 

To select an implicant highlight it by selecting the row of the implicant with a mouse click 

and press the  use selected implicant button. You may press the  reset button to undo your 

selection(s).

When all cases are covered by the selected implicants the result report is called by pressing 

the  ok button.  The  cancel button closes  the  manual  selection  window without  creating  a 

report.
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The Tosmana Report

When the calculation is finished, the result report opens in the Tosmana result window or, if 

selected, in the Internet Explorer:

You will find the settings of the calculation and (if selected) the data matrix first in the report. 

At the end, the solution and (if the option is set) the simplifying assumptions are reported. 

Unlike in earlier QCA Software, Tosmana can either use upper-/lowercase notation to display 

the results or use strict set notation. As Tosmana also allows more than two possible values 

for  each  condition,  the  upper-/lowercase  solution  can  only  be  used  to  display  strictly 

dichotomous data sets.3

Any parts of the report can be copied to the clipboard and pasted to other application by 

clicking the right mouse button and selecting copy in the popup-menu. 

Also, solutions can be directly added to the Boolean Calculator by highlighting the solution 

and selecting  Add to Boolean Calculator from the context menu pressing the right mouse 

button.4

3 Please see Charles C. Ragin (1987): The Comparative Method – Moving Beyond Qualitative and Quantitative  
Strategies for the original detailed description of using Boolean sets in social science, and Gisèle DeMeur / 
Benoit Rihoux (2002): L'analyse quali-quantitive comparée (AQQC-QCA : approche, techniques et applications  
en sciences humaines for a introduction how to apply the method.  The use of Set  Notation is explained in 
Cronqvist,  Lasse  (2003):  “Using  Multi-Value  Logic  Synthesis  in  Social  Science”.  Draft  found  on 
http://www.tosmana.net/resources. 
4Currently this only works with dichotomous data sets. The use of set notation in the report is required (unselect 
the Use Uppercase / Lowercase notation option in the MVQCA window.
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6. The Visualizer

Tosmana allows the user to display a Boolean data set with up to five independent conditions 

to be displayed graphically. To do this, select the conditions in the  MV(QCA) window and 

press the visualize button. You will then get the Visualizer window.

Please note that at the recent stage it is only possible to save the created graph as a bitmap 

file, which is rather large, but this can be edited and compressed in almost every graphic suite. 

In the Visualizer, you can toggle between Colour and Black/White display and select which 

information is shown. You might also highlight solutions of your choice.
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7. The Boolean Calculator

The Boolean Calculator allows simple calculation on Boolean Expressions like intersections 

and complements. To perform such a calculation, the Boolean Expressions have to be entered 

into the calculator. This is done in prefix notation just like using a standard pocket calculator: 

First  the single  expressions  are entered which then are connected by + and *.  When the 

logical expression is entered, it can be added to the lower calculation box by pressing the 

“add” button. An intersection of two logical expressions is calculated by selecting the two 

expressions from the expression list (using the shift key to select multiple entries) and then 

pressing the “computer intersection” button. The complement of a logical expression can be 

calculated by selecting the expression from the list and pressing the “compute complement” 

button.

From version 1.25 logical  expressions can be directly added from the TOSMANA report 

(please see page 13 on this).

8. Registration and support)

Tosmana is free software and it comes as it is: There is no guarantee for correctness of any 

part of the program. Also,  Tosmana comes to you on a  something-for-something basis: The 

software is provided to you by the author, but you also should report errors or new ideas for 

the software, so that the software can be improved. To do so, please visit the Tosmana FAQ 

on http://www.tosmana.net/faq.html. 

Registration

Tosmana is free, but we would like to know who uses Tosmana. Therefore we request you to 

register using the form online on http://register.tosmana.net. As a registered user you will be 

informed of changes in Tosmana and you will be able to ask for support on Tosmana if you 

have any questions on how to use it. You will receive a registration code when registered, 

which can be entered into Tosmana.

Updates

A  mailing  list  has  been  set  up  to  notice  about  TOSMANA  updates  (please  see 

http://www.tosmana.org/newslist.html).
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9. Citing, Technical and contact information:

If you use Tosmana please cite like this:

Version of Tosmana covered by this manual: 1.3 beta
Date of Software Release: June 5th 2007
Tosmana is developed by: Lasse Cronqvist
Email: lasse.cronqvist@tosmana.net 
Postal address: Institute of Political Science

University of Marburg

35032 Marburg

Germany
Software Requirements: .NET Framework (v. 2.0. or higher)
Download of Tosmana: http://www.tosmana.net

Cronqvist, Lasse. 2007. Tosmana – Tool for Small-N Analysis [Version 1.3]. Marburg. 

<http://www.tosmana.net>
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